flash 7 needed